... Assinatura do site por 3 anos + Kit MontaRibbons + 3 Livros em PDF + Diversas Revistas (pdf) de brinde, por apenas R$182,00
(
podendo parcelar em até 10 vezes no cartão de crédito)...

Clique aqui e obtenha mais detalhes do nosso kit completo e de como comprar.


SOMASE do Excel no Access ( intervalo de valores )

Usuário Rodrigo:

Meus agradecimentos a você, Avelino Sampaio. Obrigado pelo convite em participar do site. Desconhecia este espaço.

Bem, segue a  minha dúvida:

Imagine a seguinte tabela:

Prateleira Fruta Quantidade Quantidade Total
P1 Maçã 10 30
P2 Pêra 05 35
P3 Manga 08 24
P4 Maçã 20 30
P5 Manga 16 24
P6 Pêra 30 35

 

Perceba que o último campo está somando todas as prateleiras:

Maçã P1 + P4 = 30
Pêra P2 + P6 = 35
Manga P3 + P5 = 24

 

No MS Excel a fórmula para esta solução seria: =SOMASE(intervalo;criterios;[intervalo_soma])

Considerando (P1) como sendo A1 e 35 (último valor da tabela) como sendo D6, a fórmula do Excel acima ficaria como segue:

=SOMASE($B$1:$C$6;B1;$C$1:$C$6) <--- Cifrão usado para travar o intervalo.

Agora no Access, como fazemos isso?

Pode informar qual a fórmula que posso usar no Textbox ?

Suporte:

Rodrigo, segue o arquivo exemplo abaixo:

- Abra a tabela tblTeste e veja os lançamentos.
- Abra a consulta qryAgrupamentoPorFrutas e veja o resultado.
- Acrescente mais registros à tabela tblTeste e então abra a consulta qryAgrupamentoPorFrutas e veja o resultado.
- Abra o relatório rltAgrupamentosPorFrutas e veja o resultado. Este relatório está vinculado a consulta qryAgrupamentoPoFrutas.
- Outra forma de montagem e cálculo está no relatório rltTeste. Todas as divisões (agrupamento) e cálculos são feitos no próprio relatório.

 

Usuário :

Ilustríssimo Avelino,

não deu certo. Na verdade, deu "Super Certo". Perfeito!

Download

 


 

 


1 comentário(s)

Carvalho   19/02/2018 06:40:00

Mais um exemplo sensacional, obrigado Avelino mais...


Envie seu comentário: