... Assinatura do site por 3 anos + Kit MontaRibbons + 3 Livros em PDF + Diversas Revistas (pdf) de brinde, por apenas R$182,00
(
podendo parcelar em até 10 vezes no cartão de crédito)...

Clique aqui e obtenha mais detalhes do nosso kit completo e de como comprar.


Ribbon parou de funcionar ao dividir o meu aplicativo

Usuário Juninho:

Olá, boa tarde.

Estou com dúvida para colocar Login de Usuário no MontaRibbons, depois que divido meu banco de dados.  Fiz minha ribbon no MontaRibbons e ficou perfeita, só que, na parte de Login de Usuário eu fiz assim:

- criei uma macro com o nome "AutoExec" para carregar o formulário "Login".  Ao abrir o formulário ele executa o seguinte comando:

DoCmd.ShowToolbar "ribbon", acToolbarNo (isso faz com que a Ribbon se esconda)

Depois que coloca o usuário e senha corretos, ele executa:

DoCmd.ShowToolbar "ribbon", acToolbarYes (daí aparecem as ribbons).

Até aí tudo bem, mas quando divido o meu Banco de Dados, para que as tabelas fiquem vinculadas, este processo não executa e faz com que depois do login de usuário, as ribbons fiquem ainda escondidas.

O que pode estar acontecendo?

Agradeço pela ajuda, desde já.

Suporte:

Juninho,

se você fez a divisão pelo assistente, ele carregou a tabela UsysRibbons para back-end.  Você tem que trazer a tabela USysRibbons para o front-end.

Usuário:

Boa tarde, Sr. Avelino.

Ah, agora entendi! Não posso vincular a tabela USysRibbons.  Eu tenho que importar.  Agora deu certo!

Perfeito, muito obrigado!


 

 


Não há comentário

Envie seu comentário: